JIRA 4.0.1 Upgrade Guide

Upgrading from JIRA 4.0 to 4.0.1

Please note the following before performing this upgrade:

WebLogic 9.2 not supported

Please note that the WebLogic 9.2 patch issued for JIRA 4.0 in JRA-19367 may not work with JIRA 4.0.1 in all environments. We are addressing WebLogic 9.2 support and will provide a solution as soon as possible. If you are using WebLogic, please stay on JIRA 3.13.x in the interim.

Websphere version is important

WebSphere 6.1.0.27 is supported with JIRA 4.0.1. The version of WebSphere is important as we have seen issues running with WebSphere 6.1.0.3. Please see JRA-19421 for details. WebSphere 7.0 is not supported

Gadgets served to other servers may experience issues

As a result of fixing the 'loopback' problem (where a server had problems serving a gadget to itself), issues such as JRA-19890 may now be encountered when serving JIRA gadgets to iGoogle. As with any new and rapidly evolving technology, gadgets offer exciting opportunities — and potential technology incompatibilities. If your cross-server gadgets are working successfully with JIRA 4.0, and you rely on these gadgets for business purposes, please test them with JIRA 4.0.1 on a non-production server before upgrading.

Please follow the JIRA general upgrade instructions.

Upgrading from JIRA 3.13.x and earlier

In addition to the above (particularly regarding Websphere and WebLogic), please read the JIRA 4.0 Upgrade Guide and the Upgrade Guide for every version you are skipping during the upgrade. The complete list of Upgrade Guides is available here.

Was this helpful?

Thanks for your feedback!

Why was this unhelpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport