JIRA 6.3.3 Upgrade Notes

Please follow the instructions in the general Upgrading JIRA guide, as well as the JIRA 6.3.3-specific instructions below. The general guide contains important tasks that are essential for getting your upgraded JIRA installation to work correctly and, if necessary, migrating existing configurations.

This page also describes known issues as well as changes you should be aware of before deciding whether or not to upgrade to JIRA 6.3.3.

On this page:

Known Issue with SQL Server

We do not recommend that customers running JIRA with SQL Server 2005/2008/2012 upgrade to JIRA 6.3.3. Please watch this issue JSW-14874 - DVCS Connector failed with SQLException: Incorrect syntax near the keyword 'MERGE' Resolved for workaround and upcoming fix information.

Information for JIRA developers

See Preparing for 6.3 (this information is the same for JIRA 6.3.3) for important information that could affect your add-ons or scripts. Also, see our Java API policy for JIRA.

Upgrading to JIRA 6.3.3 from JIRA 6.2.x

End of support for Internet Explorer 8 and PostGres 8.3

JIRA 6.3.3 does not support Internet Explorer 8 (IE8) or PostGres 8.3. For more information, please see this page.

Supported Platforms

JIRA 6.3.3 had added support for Java 8, Microsoft SQL 2012, and PostGres 9.0 - 9.3. For more information, please see this page.

Upgrading to JIRA 6.3.3 from JIRA 6.0.8 or earlier

In addition to the points listed above, please read the Important Version-Specific Upgrade Notes for every version of JIRA you are skipping.

Note, you cannot upgrade from JIRA 4.3.x or earlier, directly to JIRA 6.3.3. You must upgrade to an interim version first. See Skipping Major Versions When Upgrading JIRA.

Was this helpful?

Thanks for your feedback!

Why was this unhelpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport