MySQL Administrator and Data Truncation Errors

Hi All,

Due to the release of the 3.7 branch requiring an empty database on startup (see here), a lot of our customers have had issues importing their data into the new install due to encoding inconsistencies between their existing databases and the new ones they've created for 3.7.x.

Errors that users are seeing are Data Truncation errors that look like:

org.ofbiz.core.entity.GenericDataSourceException: SQL Exception while executing the following:INSERT INTO jiraaction (ID, issueid, AUTHOR, actiontype,
actionlevel, rolelevel, actionbody, CREATED, actionnum) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?) (Data truncation: Data too long for column 'actionbody' at row 1)\
	at org.ofbiz.core.entity.jdbc.SQLProcessor.executeUpdate(

We've been told that users using 'MYSQL Administrator' to create their databases lack the ability to specify what encoding type they wish their database to use. Here is the comment we received from a customer:

I solved the problem. I used to create the database using the MySQL Adminstrator with the effect, that I could not define the character-set to use for the database. So I tried to create the database manually using the command-line tool and bang, the import of the data worked fine.

I hope this helps and saves you all some installation hiccups.


Was this helpful?

Thanks for your feedback!

Why was this unhelpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport