503 error message pop-up on JIRA indexing page after upgrade

Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

While performing background reindexing, we are seeing 503 pop up constantly. The issue happened after upgrading from Jira Service Desk to Jira Service Management application.


Environment

4.22.2

Diagnosis

  • A warning message was seen in the application-jira.log while doing a background reindexing: 

    2022-05-16 10:27:46,819+0100 Timer-1 WARN xxxxx 1141x197x1 ho0bti x.x.x.x.x /secure/admin/jira/IndexProgress.jspa [java.util.prefs] Couldn't flush user prefs: java.util.prefs.BackingStoreException: java.lang.NullPointerException
    2022-05-16 10:27:49,871+0100 IssueIndexer:thread-8 INFO xxxxxx 627x20502x1 54dt9k x.x.x.x.x /secure/admin/jira/IndexReIndex!reindex.jspa [c.a.j.w.a.admin.index.IndexAdminImpl] Re-indexing is 1% complete. Current index: Issue
  • A similar KB article - https://confluence.atlassian.com/jirakb/could-not-lock-user-prefs-unix-error-code-2-270829588.html but does not help the case.
  • Enable Plugin Safe mode

Cause

It turned out that the Insight - Asset Management app is bundled with JSM and is not enabled.

Solution

Ensure the Insight app is enabled after the upgrade. You can inspect the Insight plugin via the Manage Apps page.

Last modified on Feb 5, 2025

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