A JSM-licensed user sees "Unknown user" for user type attributes in an Assets object

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

Suppose a user with a Jira Service Management - Agent license is added(individually or as part of a group) to an Assets object type with the Object Type Manager role. When this user accesses an Assets object, the value of a User Type attribute is displayed as Unknown user in that object like below:

This scenario can also occur when the objects with User Type attributes are imported using Assets imports. You might assume that the users imported had the incorrect Atlassian Account IDs and re-try the import but that's not the case.

Environment

Jira Service Management Cloud

Diagnosis

You can start diagnosing the problem by checking if the affected user is seeing this issue for all object types or any specific object type. If the problem persists with all object types, there could be something wrong with the Jira global permissions:

  1. Navigate to https://<yoursitename>.atlassian.net/secure/admin/GlobalPermissions!default.jspa page of your cloud site
  2. Check which groups are part of the Browse users and groups global permission.

(info) The user has a JSM product license and is added to the Object type manager role as part of a group or individually.

(lightbulb) If a Project type attribute in an object contains a project that the user doesn't have access to, then the user will see that as Unknown:

Cause

The user OR the group the user is part of does not have the Browse users and groups global permission.

Refer to the page Manage global permissions to learn more about Jira global permissions


Solution

  1. You can add the affected user to any one of the groups that are already given the Browse users and groups global permission.

    To add a user to a group
    1. Go to admin.atlassian.com. Select your organization if you have more than one.
    2. Select Directory > Groups.
    3. Select the group that you want to add users to.
    4. Select Add group members and search for the users you want to add.
    5. Select Add users.
  2. You can grant the global permissions to a user group. Only site admins can manage groups of users. Read more about managing groups.

    To grant global permission
    1. Scroll to the bottom of the page to find the Grant Permission section.

    2. Select the permission you want to grant in the Permission dropdown.

    3. In the Group drop-down list, either:

      • select the group you want to grant the permission to

      • select Anyone to grant permission to users who aren't logged in.

  3. To resolve the error related to the Project type attribute, add the affected user/agent to the project's People page.

    To add a user to a project
    1. From your project's sidebar, select Project Settings> People.

    2. Select Add people

    3. Search for Emma
      You can add multiple people and groups, and delete those you have accidentally added in this dialogue.

    4. Select the Administrator role and select Add


Last modified on May 29, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.