A3 BAD Request is throttled. Suggested Backoff Time when using JIRA with Office365
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
The following appears in the atlassian-jira.log
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2018-08-26 06:02:15,538 Caesium-1-3 ERROR anonymous XXX Mail Handler [c.a.mail.incoming.mailfetcherservice] XXX Mail Handler[10001]: Messaging Exception in service 'com.atlassian.jira.service.services.mail.MailFetcherService$MessageProviderImpl' when getting mail: A3 BAD Request is throttled. Suggested Backoff Time: 165839 milliseconds
javax.mail.MessagingException: A3 BAD Request is throttled. Suggested Backoff Time: 165839 milliseconds;
nested exception is:
com.sun.mail.iap.BadCommandException: A3 BAD Request is throttled. Suggested Backoff Time: 165839 milliseconds
at com.sun.mail.imap.IMAPFolder.logoutAndThrow(IMAPFolder.java:1178)
at com.sun.mail.imap.IMAPFolder.open(IMAPFolder.java:1085)
at com.sun.mail.imap.IMAPFolder.open(IMAPFolder.java:999)
at com.atlassian.jira.service.services.mail.MailFetcherService$MessageProviderImpl.getAndProcessMail(MailFetcherService.java:225)
at com.atlassian.jira.service.services.mail.MailFetcherService.processMessages(MailFetcherService.java:404)
at com.atlassian.jira.service.services.mail.MailFetcherService.runImpl(MailFetcherService.java:396)
at com.atlassian.jira.service.services.file.AbstractMessageHandlingService.run(AbstractMessageHandlingService.java:229)
at com.atlassian.jira.service.JiraServiceContainerImpl.run(JiraServiceContainerImpl.java:68)
at com.atlassian.jira.service.ServiceRunner.runService(ServiceRunner.java:62)
at com.atlassian.jira.service.ServiceRunner.runServiceId(ServiceRunner.java:44)
at com.atlassian.jira.service.ServiceRunner.runJob(ServiceRunner.java:32)
at com.atlassian.scheduler.core.JobLauncher.runJob(JobLauncher.java:153)
at com.atlassian.scheduler.core.JobLauncher.launchAndBuildResponse(JobLauncher.java:118)
at com.atlassian.scheduler.core.JobLauncher.launch(JobLauncher.java:97)
at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.launchJob(CaesiumSchedulerService.java:443)
at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.executeClusteredJob(CaesiumSchedulerService.java:438)
at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.executeClusteredJobWithRecoveryGuard(CaesiumSchedulerService.java:462)
at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.executeQueuedJob(CaesiumSchedulerService.java:390)
at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService$1.consume(CaesiumSchedulerService.java:285)
at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService$1.consume(CaesiumSchedulerService.java:282)
at com.atlassian.scheduler.caesium.impl.SchedulerQueueWorker.executeJob(SchedulerQueueWorker.java:65)
at com.atlassian.scheduler.caesium.impl.SchedulerQueueWorker.executeNextJob(SchedulerQueueWorker.java:59)
at com.atlassian.scheduler.caesium.impl.SchedulerQueueWorker.run(SchedulerQueueWorker.java:34)
at java.lang.Thread.run(Thread.java:748)
Caused by: com.sun.mail.iap.BadCommandException: A3 BAD Request is throttled. Suggested Backoff Time: 165839 milliseconds
at com.sun.mail.iap.Protocol.handleResult(Protocol.java:399)
at com.sun.mail.imap.protocol.IMAPProtocol.select(IMAPProtocol.java:1245)
at com.sun.mail.imap.IMAPFolder.open(IMAPFolder.java:1056)
... 22 more
Diagnosis
Using Office365 as Incoming Mail Server.
Cause
Office365 Exchange Online Throttling and Limits is not allowing JIRA to read emails from the Email Inbox;
Solution
Resolution
Get in touch with Office365 support to fine tune the Throttling and Limits on Exchange Server.
An alternative workaround which has been reported to alleviate this problem for some organizations is to stagger how often mail handlers are checking mail by using various values for the 'Delay' field for all mail handlers you have
Navigate to 'Settings > System > Incoming Mail'.
Edit an existing Mail Handler and change the value of Delay to an acceptable delay for the project (the default value is 1, which means this mail handler is checked every 1 minute).
Repeat for all other mail handlers and use various values for Delay.
The purpose of this is to reduce the frequency Jira checks mail for all these mail handlers such that it does not trigger Office365 limits.
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