Adding invalid JQL in new service project queue will cause the Queue screen to show as Empty

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Adding invalid JQL in new service project queue will cause the Queue screen to show as Empty.

  1. Go to Project > Queue >New queue.
  2. On Issues to show field > Go to Advance and add invalid JQL such as below:

    assignee was not in (EMPTY)
  3. Click Save to add the new queue.

  4. During saving, no indication that the JQL are incorrect and Queue page will show as Empty.

Cause

JSDSERVER-6675 - Getting issue details... STATUS

Workaround

As a workaround, you would need to update the JQL column from "AO_54307E_QUEUE" table and Restart Jira:

update "AO_54307E_QUEUE" SET "JQL" = '<ADD_VALID_JQL_HERE>' where "ID"=<ID_affected_queue>;

Replace the JQL value to a valid JQL and ID to affected Queue ID.


Always back up your data before performing any modifications to the database. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.



DescriptionAdding invalid JQL in new service project queue will cause the Queue screen to show as Empty
ProductJira Service Management
Last modified on Nov 23, 2020

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