Adding new Slack Workspace for Incident Management results in "We couldn't connect the workspace" error message.
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When you are connecting a Slack Workspace for Incident Management by following the steps in Connect a new Slack workspace to your service project you see the below error:
Environment
Jira Service Management Cloud.
Cause
We run into this error due to permission issues with Jira or incorrect permissions set in Slack or Licensing.
Solution
When adding the Slack workspace for Incident Management make sure the below conditions are met:
Jira permissions:
- You need to be a Jira admin - Reference: Give users admin permissions.
- If you have Standalone OpsGenie under the same cloud site you need to be a Opsgenie licensed user - Reference: Learn user roles and permissions.
Slack permissions:
- You need to be a Slack admin - Reference Slack support documentation: Manage owner and admin roles.
- Channel Management permission in Slack needs to allow Everyone to create public channels - Reference Slack support documentation: Manage permissions for channel management tools.
In case you are still facing an issue with adding a Slack workspace feel free to contact support via the Support portal.