Adding users to an organization or creating a new one fails with the error sd.customer.organisation.ids.error.not.found in Jira Service Management Data Center
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Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When trying to add users to an organization or while creating a new organization, the action fails with the error below:
sd.customer.organisation.ids.error.not.found
Environment
Any Jira Service Management Data Center version.
Diagnosis
The organization is correctly found in the database when using the SQL below:
select * from "AO_54307E_ORGANIZATION";
The REST API endpoint "/servicedeskapi/organization" also returns the relevant organization, which confirms that the organization exists in the database.
Cause
The Jira Data cache is out of sync with the database.
Solution
To resolve this issue, the data cache needs to be flushed and re-built from the database by re-starting the Jira application (in case of a single node), or performing a rolling re-start of each node (in case of a cluster of nodes).