Administrator Cannot Login After Reordering User Directories
Symptoms
After reordering User Directories in JIRA, an administrator cannot log in despite providing correct credentials.
Cause
There is a duplicate user with the same username in a directory with a newly-reordered higher position. Currently, JIRA does not support 'shadowed' users. This is a known limitation tracked in JRA-23861 - An admin can lock themselves out of JIRA by changing the order of the User Directories.
Resolution
Option 1:
Request the assistance of another administrator and ask them to revert the ordering modification.
Option 2:
Temporarily disable the directory in the higher position with help of SQL.
Always back up your data before performing any modification to the database. If possible, try your modifications on a test server.
List all currently defined directories:
select id, directory_name, active from cwd_directory; ID DIRECTORY_NAME ACTIVE ----- ----------------------- ------ 10102 AD win2k8 1 1 JIRA Internal Directory 1 10106 Active Directory server 1 3 row(s) in 0 ms
Disable the conflicting directory. In our example we will disable directory with ID 10102:
update cwd_directory set active=0 where id=10102
- Restart Tomcat in order to apply the change.