After renaming existing issue type, old issue name is still shown on the issue create drop down menu
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When an existing issue type is renamed, the Issue type dropdown on the Issue creation screen lists out the old issue type instead of the new Issue type.
Environment
Jira Cloud
Diagnosis
- Rename an existing issue type. For example, rename the "Testing" issue type to "New testing"
- From Settings > Issues > Issue types confirm the newly renamed issue type appears
- Go to the project, and click on Create button to create a new issue.
- On the creation screen, the old issue type name is displayed in the drop-down
- Go to Project Settings > Issues > Types, the old issue type is displayed
- Navigate to Settings > Issues > Issue types and click on the (...) against the issue type, and select Translate. You'll notice a translation added to the affected issue type which consists of the old issue type name.
Cause
The translation added to the Issue type is reflected on the Create Issue screen
Solution
- Remove the translation from Settings > Issues > Issue types > Select issue > Translate and Update the changes
- Click on Create to create a new issue, and you'll now see the updated Issue type in the drop-down.