Agile Boards Unavailable in JIRA Agile After User or Filter Deletion

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms 

User advises they are unable to see agile boards that were available previously on their instance.

Cause

The instance has had either of the following deleted recently:

  • User profile
  • Search filter associated with agile board

The deletion of either of these values affects the database associations and permissions of displaying the board. 

Resolution

The user will need to recreate the filters for their specific boards:

project = ABC ORDER BY Rank ASC

You will need to confirm which filter is to be associated to each board (if multiple boards were affected).

You can confirm the boards to the user via:

 select * from "AO_60DB71_RAPIDVIEW";

and confirm the ID's of the new searches via:

select * from searchrequest;

To resolve the connection, confirm the new user profile and/or search filter to be used and perform an update on the database via:

UPDATE "AO_60DB71_RAPIDVIEW" set "SAVED_FILTER_ID" = <new filter> where "ID" = <x>;
and/or
UPDATE "AO_60DB71_RAPIDVIEW" set "OWNER_USER_NAME" = <new username> where "ID" = <x>;

A JIRA service restart is required after this amendment.


Last modified on Feb 26, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.