All the Requests Types are spinning forever on the JSM customer portal
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After upgrading some 3rd party add-ons in Jira via the page ⚙ > Manage Apps > Manage Apps, the following symptoms happen:
- any Requests Type stopped loading on the Jira Service Management (JSM) customer portal. Part of the page is loading, but most of the content is blank and there is a spinning wheel:
- after a refresh of the page, the spinning wheel disappears, but most of the content of the page is blank:
Environment
Observed on Jira Service Management Server/Data Center 4.20.10 (although other versions might be impacted)
Diagnosis
- Go to the page ⚙ > Manage Apps > Manage Apps, and check if the add-on Group Sign-Off: parallel Multi-Approvals is installed
- If it is installed, check the installed version. If the add-on is on 2.8.0 or any higher version:
- try to temporarily disable this add-on
- if the issue goes away, then this KB article is relevant and you can move on to the Solution section
Cause
The 3rd party add-on Group Sign-Off: parallel Multi-Approvals is causing the request type loading issue.
Solution
The solution is to downgrade the add-on to any version lower than 2.8.0, for example 2.7.8, by following the steps below:
- Go to the add-on version history page and download the version 2.7.8
- In Jira, go to ⚙ > Manage Apps > Manage Apps
- Look for the add-on an uninstall the add-on
- Re-install it by uploading the 2.7.8 jar file of the add-on using the button Upload app
If you need to use the latest version of this add-on, we highly recommend to reach out to the add-on support team about this issue to get further assistance, since Atlassian does not support it.