Application installation fails with error "We are unable to process your request as there is no default group in Jira cloud product access. Please review and create a default group for each product."
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Can't install apps on cloud site. The error on the UI states there is no default access group.
Environment
Jira Cloud.
Diagnosis
Any application installation first involves creating an app user that would need the product access(this is not ideally the license since these are app users). Therefore, this step errors out if there is no default group for all/any products and in the backend, we can see user creation errors out.
Sometimes the admins might have deleted the default and replaced it with another. This could have resulted in such issues.
Cause
This is likely due to changing the default access group and that isn't completely synced. Therefore, Jira still believes that there isn't a default access group.
Solution
- Check if all products have the default access group, if not then add one.
- If all products do have a default access group set and the issue still persists try the below steps:
- Create a dummy group.
- Add this group to the product access tab.
- Set this group as the default access group(do it for one product at a time if you have more than one).
- Install the application.
- Revert the previous changes, that is, remove the dummy group as the default access group and from the Product access.
- Try installing any application, it should continue to work.