Application Link not working when linking to Jira Service Management
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Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
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Summary
Application link between Jira Software and Jira Service Management not working with an OAuth mismatch error.
We have to use regular OAuth and not Oauth with impersonation for some time until our usernames match again, and when trying to set the Application link between Jira Software and Jira Service Management, we receive an OAuth Misconfig error.
Environment
Jira Software 8.5.8
JSD 4.5.8
Diagnosis
When trying to link using OAuth, we can see this error in the UI:
OAuth mismatch
The local incoming connection uses OAuth, however “JSD” uses OAuth with impersonation
The local outgoing connection uses OAuth, however “JSD” uses OAuth with impersonation
On atlassian-jira.log, we can see the following error on both instances:
2020-11-06 13:44:21,575-0600 http-nio-8080-exec-15 WARN diegovb 704x43960x2 u0t60i 10.230.56.90 /rest/applinks/3.0/status/d54hg145-2ee3-3325-ba88-d3253f535gv [c.a.a.i.migration.remote.TryWithCredentials] You do not have an authorized access token for the remote resource.
Cause
Jira Service Management requires to use OAuth with impersonation
Solution
Create an Application link between Jira Software and Jira Service Management using OAuth with Impersonation.
JSDSERVER-7053
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Getting issue details...
STATUS
Opened for documentation improvement on this topic.