Assets do not appear in Issue View after importing issues
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Importing issues in Jira supports updating Assets fields, however, despite the import not throwing any errors, it can sometimes result in broken Assets fields in the Issue View.
Diagnosis
When opening an issue through Issue View, an error icon will appear in the Assets field with the following message on hover:
There was a problem loading the Assets objects. Please refresh the page to try again.
Cause
The Assets Workspace ID referenced in the value of the Assets field does not match the instance Assets Workspace Id.
Solution
- Get the instance Assets Workspace ID using the following endpoint: https://<instance>.atlassian.net/rest/servicedeskapi/assets/workspace
- Replace the Workspace ID in the CSV file
- Import the data again