Assets do not appear in Issue View after importing issues

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Importing issues in Jira supports updating Assets fields, however, despite the import not throwing any errors, it can sometimes result in broken Assets fields in the Issue View.

Environment

Jira Service Management Cloud

Diagnosis

When opening an issue through Issue View, an error icon will appear in the Assets field with the following message on hover:

Error Message
There was a problem loading the Assets objects. Please refresh the page to try again.

Cause

The Assets Workspace ID referenced in the value of the Assets field does not match the instance Assets Workspace Id.

Solution

  1. Get the instance Assets Workspace ID using the following endpoint: https://<instance>.atlassian.net/rest/servicedeskapi/assets/workspace
  2. Replace the Workspace ID in the CSV file
  3. Import the data again

Last modified on Jan 29, 2024

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