Assets import process encountered an exception: rlabs.insight.i18n.constraint.violation.ObjectAttributeValueBean.NotFound.Users in Data Center

Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

 

Summary

When running asset imports, an import failure occurs due to the following exception: "rlabs.insight.i18n.constraint.violation.ObjectAttributeValueBean.NotFound.Users"

Environment

JSM 5.12.x

Diagnosis

The following entries can be seen in the atlassian-jira logs.

2024-11-14 13:06:23,607+0100 insight-InsightThreadGroup-worker-thread-27 WARN  [c.r.j.p.i.s.i.schema.log.ImportLogger] Unable to update references on object user atlassian (TEST-16935), [HAVING_OBJECT_REFERENCE] due to validation exception. Check your attribute configuration Error messages: context: rlabs-insight-attribute-887; messages: [ErrorMessage{i18nKey='rlabs.insight.i18n.constraint.violation.ObjectAttributeValueBean.NotFound.Users', parameters=[JIRAUSER21100], additionalMessage=null}]; 


Cause

The Synchronizing Account, which refers to the Jira user specified in the import configuration, lacks the necessary permissions to browse users in Jira.


Solution

  • Go to Jira > Settings > System
  • On the left side menu, click Global permissions
  • Scroll to the bottom of the permissions page
  • Ensure that "Browse users" is assigned to a group to which the user specified in the Asset Import Configuration is a member.



Last modified on Dec 10, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.