Atlassian Assist adds Reporter's Comments on ticket as 'On behalf of User'
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
- When a user comments on a ticket via Slack the comments might get added as [On behalf of @<User>]. This normally happens when the user does not have the required permissions.
- However, this might also happen to the Ticket Reporter.
Environment
JSM Cloud
Cause
- This could happen due to Issue Security configuration. If the Reporter is not a part of Issue Security Level (which provides access to the issue), then they will face this problem.
Solution
- Add the Reporter to the required Issue Security Level.
- Please refer to this article for more details on Issue Security Configuration.