Automation Rule Error on Successful Transition

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

 

Summary

The automation rule fails with the "Error transitioning issue" even though the transition completed successfully.

Diagnosis

In the rule's audit log you will see the below error when transitioning the issue even though the issue was transitioned successfully:

Transition issue

Error transitioning issues
(Can't move KEY-123). You might not have permission, or the issue is missing required information. If you keep having this problem, contact your Jira Administrator.)

Image with the error described above

Cause

The problem is caused by two Automation rules configured so that both of them are trying to transition the same issue at the same time. While one of them succeeds, the other gets errors while transitioning the same issue.

Solution

  • Check the Rule Execution on the ticket to confirm which rules were applied to the ticket. 
    An image showing the Recent rule execution on a ticket in Jira Cloud
  • Review rules configuration to identify which ones were performing the same action.
  • If all the rules don't appear on the issue view then you need to check the global automation audit logs and check all the rules that triggered for that issue during that time: https://YOURSITE.atlassian.net/jira/settings/automation#/tab/audit-log
  • Once identified, you can select to change, disable or combine one of the rules causing the problem. 
Last modified on Nov 26, 2024

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