Automation rule is failing with "Could not find your configured field, it may have been deleted, or may need to be added to the project "
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
The automation rule is failing with "Could not find your configured field, it may have been deleted, or may need to be added to the project " for edit issue action
Environment
Jira Service Management Cloud
Diagnosis
- Check if the field added in the edit issue action in automation rule is added in the Issue type screen
- This can be verified by going to Project settings > Screens
- If the field is added in the associated issue type screen then on a particular issue view find the field
Select ··· > Find your field.
Search for the field you want to find.
Select the field.
Check if there are any errors.
Cause
There can be multiple reasons for this error to occur.
In this case the affected field "impact" was not configured in the scope of Project and issue type.
Solution
To rectify the errors, follow the steps below:
- Check the Custom field context by following the below steps
Navigate to Cogwheel > Issues > Custom fields
Search for the affected field, then click on
... > context and default values
If the project or issue type is not added in the context of the custom field then add the project or the associated issue type to the context.
- Below are the steps to add the project and associated issue type to the context.
Select > Issues.
Under FIELDS, select Custom fields.
Find the custom field you want to configure and select > Contexts and default value > Add new context.
Enter a label and description for your new context. These are used for your reference in the administration section only and will not be shown to your end-users.
In the applicable issue types section, select the issue types that you want this custom field to appear in.
In the applicable contexts section, select a global context or choose specific projects that you want this custom field to appear in. Note that the custom field will only appear on issues types you previously selected.
Select Add
- Below are the steps to add the project and associated issue type to the context.
Additionally, Check the default configuration scheme of the custom field
Add project or associated issue type to the context ( Follow the same steps mentioned as above)
Reference : Configure custom field context