Automation Rules in Jira Service Management will not execute when triggered by comments added by Jira Incoming Mail handler

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Symptoms

Automation Rules in Jira Service Management will not execute when triggered by comments added by Jira Incoming Mail handler and when the rules are configured to run “Run as the user who triggered the rule”

Cause

Emails from Jira Incoming Mail handler are not using the same permissions as Jira Service Management Email Channel.

Jira Incoming Mail handler “operates” outside of Jira Service Management. Even though it can be configured to perform certain actions on Jira Service Management issues (such as adding comments), its’ functionality in Jira Service Management is limited.

In case of this particular issue for example Jira Service Management is not able to authorise the user to execute an automation rule as the request came from outside the Service Management. 

There are 2 workarounds for this issue (see below).

A bug report exists also to address this limitation:

https://jira.atlassian.com/browse/JSDSERVER-5735


Workaround

Option 1

The preferred method of configuring Incoming Email for Jira Service Management is by 

Setting up the Email Channel


Option 2

If using Jira Incoming Mail handler (Jira -> System -> Incoming Mail) is the only option, please configure the Automation Rules to “Run as Project Default”.



Last modified on Nov 23, 2020

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