Automation to append the dropdown select list Options based on Customer Input
Summary
This article delineates the procedure to capture the options value a designated text field, followed by the subsequent action of transferring these options to populate another dropdown select list field.
Environment
Jira Service Management Cloud
Jira Cloud
Diagnosis
Here in this article, we take a scenario where the JSM Customer fills out a Text Field from a customer portal, and Jira Automation adds this value to a Custom Drop Down Select List field to be used in Jira Issue View
Solution
We will use Rest API to add the options to a select list drop-down field.
- API Calls to Get the Context of the Custom Field ID: Get Field Context
- API Call to update the Options in the DropDown Field: Update the Options
Use the steps below to configure a rule