Blank Columns in the Queue are not exported in CSV.
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Symptoms
When trying to export issues with custom fields, unfiled fields are not exported in the CSV file.
EXAMPLE: CSV file not showing the (Approvers) Custom Filed:
Cause
The custom field is not filed with an input, is empty, or has no default value attributed to them. CSV is a Comma-Separated-Values file format it cannot handle empty values. Therefore the CSV file will not show the custom field that has no data to be processed in them.
Solution
You can set a default value so it won't show the custom field as empty:
- Go to your JSM Instance > Cog icon.
- Issues > Under Fields, select Custom fields.
- Search for the custom field you wish to edit > click on the (...) icon.
- Contexts and default value > Edit default value.
- Set the default value for the custom field.