Blank space in email sent via Jira Automation while using tables in issue description


Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

The issue description is not being displayed in the expected table format in email sent via an Automation.

Environment

  • Create an issue with a table format in description
  • Ran an automation that sends an email with the description of the issue.
  • Upon receiving the email, we can observe that table format is missing and email displayed the table in plain text with raw formatting.
  • To resolve the formatting issue we can use smart value (issue.description.html) in automations.
  • However, this introduced unneeded blank spaces in the emails above the table

Diagnosis

It seems the extra space depends on the renderer, as we can see very less space in web based gmail compared to an Outlook client. Sharing the different screenshots for quick reference:

Solution

In Send Email action under automation, there is a More Options button. Under this option uncheck the box "Convert line breaks to HTML line breaks". 



Last modified on Aug 30, 2023

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