Error "Could not fetch Assets objects" in Assets object custom field

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

 

Summary

When trying to search for Asset objects in an Asset objects custom field, one of the below errors is returned.

The Jira Server was contacted but has returned an error response. We are unsure of the result of this operation.

Could not fetch Assets objects. Please refresh the page and try again

Environment

Jira Service Management and JSM Assets 

Cause

Cause 1: Some attributes mentioned in the sections Allow search filtering by these attributes and/or Object attributes to display on issue view of the Asset object custom field configuration are unavailable in the attribute list of that Assets object type. 

Cause 2: It can happen due to the bug JSDCLOUD-11564 - Getting issue details... STATUS You are hitting this bug if you cannot browse an Asset object custom field on a workflow transition because the field is not associated with any screen(Create/View/Edit) in use by the affected Issue type. 

Solution

Solution for Cause 1

  1. Go to your cloud site.
  2. Click on Settings(cog wheel) > Issues > Custom fields
  3. Search for the Asset object custom field and right click on the 3 dots(...) beside it
  4. Click on Contexts and default value and then Edit Assets object/s field configuration
  5. Open the cloud site in another tab or just duplicate the already open tab.
  6. Click on the Assets option from the top menu bar and then View all object schemas
  7. Click on the object schema which has the object type
  8. Select the object type and go to its Attributes tab
  9. Compare the attributes from step 4 and step 9.
  10. In the Edit Asset object/s field configuration section of the Asset object custom field, remove the attributes which are not present in the Attributes tab of the object type.
  11. Once done, click Save to save the changes.


Solution for Cause 2

Please make sure that the Asset object custom field you are trying to browse on the workflow transition exists on at least one of the screens (Create/Edit) in use by the affected Issue type. To find the screens:

  1. Go to Projects settings > Screens 
  2. Expand Screen Scheme in use by the affected issue type
  3. Click on one of the screens in use by Create/Edit operations 
  4. Add the Assets object field


Last modified on Jan 29, 2024

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