Can't search on custom field
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Unable to select a few custom field checkboxes while searching for issues. It's showing a red exclamation mark with the message "<Customfield Name> is not applicable for the current project and/or issue type".
Environment
Jira Software v8.x and above.
Diagnosis
- In the Issues Search Navigator select a custom field, from the More dropdown.
- An error appears: "<Customfield Name> is not applicable for the current project and/or issue type".
Cause:1
The Search Template value could have been changed in the respective Custom Fields.
For Example - Search Template is changed to None :
Cause:2
A field is "not applicable" when the context for the custom field does not place it on that project and issue type.
Cause:3
The custom field might not have been associated with the project screens.
Cause:4
This could occur when the custom field is hidden from the Project's Field Configuration.
Solution: 1
1. Go to Jira Settings > Issues > Custom fields.
2. Find the respective field and Edit.
3. Set the Search Template value to Free Text Searcher if it is a Text Field type custom field.
Solution: 2
1. Go to Jira Settings > Issues > Custom fields.
2. Select Configure under actions => Edit Configuration. You can find a context that specifies projects and/or issue types where the field belongs.
3. Please change the context with respect to the filter search you're looking for.
Solution: 3
1. Go to Jira Settings > Issues.
2. Select Field configurations and configure.
3. Search for the custom field and click on screens to verify if the custom field is associated with the project screens.
Solution: 4
1. Go to Jira Settings > Issues.
2. Select Field configurations and configure.
3. Search for the custom field and click on Show to verify.