Cannot delete an issue type and unable to find issues associated to a deleted issue type
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When attempting to delete an issue type, Jira will inform you about how many issues are still utilizing that particular issue type:
This article provides solutions for when:
- You can't delete an issue type because some issues are still using it.
- You can't find at least some of the issues of an issue type you want to delete with the advanced search.
Clicking the n active issues link in the below screenshot redirects to a page where the issues are not found:
This behaviour is documented in the following open feature request:
JRACLOUD-80963: Deletion of an issue type being used by an issue of an archived project is not possible.
Please consider this KB article as a workaround until the feature request is implemented.
Environment
Jira Cloud
Cause
Jira Cloud doesn't allow the deletion of a particular issue type if there are issues still utilizing it. If you can't find some of the issues reported by the Delete Issue Type page, those may belong to an archived project.
Even issues of archived projects will prevent the proper removal of an issue type. So, you may need to first restore the archived project and then re-assign those to a new issue type. Only then will you be able to delete the Issue Type.
The steps to restore an archived project are listed here: Restore a project
Diagnosis
Issues are stored in the database on a cloud platform, so contact Atlassian Support to get the list of projects to which those issues belong.
Check if the missing issues belong to a project that is archived:
Choose
> Projects.Select Archive from the sidebar.
Search for the projects that are recommended by the Atlassian support team.
Solution
As mentioned above, Jira doesn't allow for Issue Types that are still being used to be deleted, thus, we'll need to re-assign those issues to a new type, which will also require any archived issues to be restored.
Begin by restoring the archive project for a given Issue Type. If there are many issues to be restored, you may also use the Restore deleted or archived project REST API endpoint to facilitate the operation.
- Try deleting the issues again and now click the link
Select all the issues and click Next:
Select the Move Issues operation and click Next again. This operation will move issues to new projects and issue types:
- Select the new Issue Type for each project and click Next:
- For any required field, select the Field Value to retain its value after the move. If you want to send an email for this update, enable the
- On the Confirm changes screen, review the changes and click Confirm:
After all issues have been moved to a new type, you can proceed to delete the issue type.
Contact Atlassian support if you have any questions.