Cannot find issue on project board when created using RestAPI

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

Issues created using RestAPI do not directly appear on the board. 


Environment

JIRA Cloud

Team managed projects

Diagnosis

If issues are created using API, they are not seen on board however if created directly on board they can be seen. Issue sare however available in the issues list.

Cause

This happens when the backlog feature is enabled. By default, if a new issue is created using the CREATE button or API or any other way, the "issue" will go to the backlog by default. The"issue" appears on board only if directly created on board or is pulled from backlog to board queue. 

Solution


There are two options available : 

  • Pull issue from backlog to board queue
  • Disable the "Backlog" feature available at "project settings" > features.

Last modified on Sep 26, 2022

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.