Cannot login as sysadmin after import backup from JIRA OnDemand to JIRA Standalone

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Symptoms

  • User login but unable to perform some System Administrator functions such as indexing, backup and restore option, user directories and etc. More information on difference between System Administrators and Administrators can refer to here. 
  • Found a sysadmin user in JIRA after import using OnDemand backup

Cause 1

System Administrators in JIRA OnDemand only available for Atlassian Ondemand Technical Support but not the Administrator users. After import from OnDemand backup, administrator user would not able to view or configure some system feature unless they login using sysadmin user.

Cause 2

It's also possible that you're running into this bug: JRA-37574 - Getting issue details... STATUS

Resolution

The password for sysadmin user will be set to sysadmin by default after the import from JIRA OnDemand backup to JIRA Standalone. You would required to login as sysadmin user and and change the password immediately after the import. For more information, you can refer to the fourth step of the instructions on the migration documentation.

Workaround

If the above resolution is not working for you, you can manually retrieve the password through database modification as instruction in this documentation and replace the username with sysadmin. The database update query will reset the password to sphere to the sysadmin. 

Please backup your database before execute the database sql query.

Last modified on Aug 12, 2022

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