Clicking on "Add comment" in a Jira Service Management issue redirects to a new page
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When clicking on "Add comment" in a Jira Service Management issue, instead of opening a comment box on the same page, users are redirected to a new page without the details from the issue:
Environment
Jira Service Management 5.0.0+
Cause 1
A Jira Service Management version affected by the following bug is being used: JSDSERVER-11937 - Getting issue details... STATUS
Cause 2
The service-desk-comment-field module from Jira Service Management is disabled.
Solution 1
Update Jira Service Management to any version that contains the fix for JSDSERVER-11937 - Getting issue details... STATUS
Solution 2
Enable the service-desk-comment-field module with the following steps:
- Go to Administration (⚙ icon) > Manage apps, then click on "Manage apps" again in the left menu
- Select "All apps" in the app filter, then search for "Jira Service Management."
- Click on it to expand its details, then click on '+' to expand its list of modules
- Search for service-desk-comment-field. If this module is disabled, click on "Enable."