Clicking on "Add comment" in a Jira Service Management issue redirects to a new page

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

    

Summary

When clicking on "Add comment" in a Jira Service Management issue, instead of opening a comment box on the same page, users are redirected to a new page without the details from the issue:

Environment

Jira Service Management 5.0.0+ 

Cause 1

A Jira Service Management version affected by the following bug is being used: JSDSERVER-11937 - Getting issue details... STATUS

Cause 2


The service-desk-comment-field module from Jira Service Management is disabled.

Solution 1

Update Jira Service Management to any version that contains the fix for JSDSERVER-11937 - Getting issue details... STATUS

Solution 2

Enable the service-desk-comment-field module with the following steps:

  1. Go to Administration (⚙ icon) > Manage apps, then click on "Manage apps" again in the left menu
  2. Select "All apps" in the app filter, then search for "Jira Service Management."
  3. Click on it to expand its details, then click on '+' to expand its list of modules
  4. Search for service-desk-comment-field. If this module is disabled, click on "Enable."


Last modified on Nov 5, 2024

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