Cloning issues with Issue Security Scheme levels via Automation
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
This article covers workarounds for the scenario where an issue is cloned between projects using Automations and the source project has a security level applied to the issue causing the cloned ticket to becomes inaccessible.
Diagnosis
The underlying cause for this behavior is documented in the following bug report: AUTO-404 - When cloning an issue through Automation rule, security level value is copied even though the security level is not available in the created issue's project
Cause
The Automation clone process defaults to cloning the security level applied to an issue even if it is not directly specified in the Clone action in an Automation rule. Additionally the automation rule and cloning process does not validate whether the Issue Security Scheme and security levels between the two projects are the same.
Solution
Both of the following methods will require the Security Level field to be added to the Automation rule's Clone action:
To add the Security Level field to the Automation action:
- Click the Choose fields to set... drop down option
- Search for Security Level in the list
- Check the check box next to the field name for it to show on the clone action
Specify the Security Level during the clone process
If both projects are using Issue Security Schemes and the intention is that the cloned issue will have a security level associated with it, a specific Security Level value can be set during the cloning process.
The chosen Security Level must exist on the destination project in order for users that are permitted by the security level to access the cloned issue.
Clear out the Security Level value
An alternate option is to clear out the Security Level field value during the cloning process. This removes the need for an Issue Security Scheme needing to be associated with the destination project.
This can be achieved by setting a smart value that does not exist as a placeholder. This is because if a given smart value does not exist, it will return an empty reference. More information on this smart value behavior can be found on the Jira Smart Values documentation.
An example of a smart value that would return an empty response would be {{clear}}
.
As seen in the above screenshot, enter the smart value into the field and select the drop down option for Smart value '{{clear}}' to set it.