Common issues with Assets caused by user-installed apps

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

There are some visual bugs or glitches on an issue/request/Assets object view 

Environment

Jira Service Management since 4.x with Assets installed and in use

Diagnosis

Here's a list of the known symptoms.

  • Jira issue view has a different layout where the Activities section, which is usually on the left bottom of the page, appears on the right side of the page. This behavior is only observed on Jira issues that contain at least one Assets custom field with value.

  • In an Assets object, users couldn't navigate through tabs like Connected tickets, Comments, and History as clicking on these tabs did not respond. It might take many mouse clicks to load a different tab.

  • When viewing a Jira issue, the selected object on the Assets custom field doesn't show all the expected attributes per the custom field configuration. If a user edits this issue, the user will find that the Assets custom field does not have the drop-down available, only the magnifying glass icon and maybe the plus icon on the right side. In the space where the drop-down usually is, the description of the custom field is seen (if exists).

    Expand to see an example screenshot

    (Auto-migrated image: description temporarily unavailable)
  • Consider a Service Management request with one Assets custom field and another one referencing this custom field. On request creation, the user filled in both Assets custom fields and afterwards removed the object from the first custom field. When the user wants to select an object again from the first custom field, the dropdown becomes distorted, and it's not possible to find and select a new object. The user has to refresh the page or create the request on a new page.

Cause

The exact cause is not known, it also varies from app to app. In general, these odd behaviors are caused by some user-installed apps.

Some known user-installed apps used to cause symptoms described above are

Solution

  1. Verify if the issue persists in Jira safe mode. Downtime might be required as all user-installed apps will be disabled in safe mode, which could impact users and businesses.

  2. If the issue is not reproducible in safe mode, we can confirm that one of the user-installed apps is causing the issue.

  3. Disable one user-installed app at a time and test if the issue is reproducible.

  4. If the issue is not reproducible when a specific app is disabled, identify the vendor and contact the vendor for support. This information can be obtained from Atlassian Marketplace.

Updated on March 21, 2025

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