Connecting Request type to Chat channels with Slack generates an error in Jira Service Management Cloud
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When trying to change the Request types associated with channels in JSM Chat project admins receive the following error:
Something went wrong
We were unable to update this channel settings. If this continues, please <button> contact support <button>
Cause
This usually occurs on JSM Chat and Slack integrations when the user account that is trying to set the Request type settings is not a part of Slack, is deactivated, or doesn't have the necessary permissions on Slack team.
Solution
Use and admin account or an account that has permissions in Slack and JSM, then:
- Access the JSM project
- Go to Project settings > then Chat
- Modify the connected channels with the desired Request types