Internal users showing duplicate on user picker fields

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Summary

If a user is added as a Jira Service Management portal-only customer before creating their Atlassian Account, they will have two user accounts within a Jira instance with the same email address and will show duplicate on user picker fields, such as reporter, assignee, and approver.

Environment

Jira Service Management Cloud

Steps to Reproduce

  1. Ensure your email address is not currently associated with an Atlassian Account 

  2. Browse to a Service Management Project > Customers > Add customers and add a customer using the email address

  3. Navigate to https://admin.atlassian.com/s/Your_site_ID/users (User Management) > Invite > Users and add a user using the same email address

Diagnosis

  • Two users now exist: one portal-only customer and one standard Jira user with application access

  • Both users have the same email address, which means:

    • Users cannot see issues they created with their original customer login

    • Users will show duplicate on user picker fields


Before Migrating:

  • Newly migrated customers must log in using their Atlassian Account credentials after you migrate them. If they're new to Atlassian Cloud, they need to verify their email address.

Solution

The problem can be mitigated by doing the following, but it does not prevent future occurrences of the problem.

Use the Atlassian migration tool to migrate the portal user to a full Jira user with application access

  1. Browse to User Management > Jira Service Management (YourDomain.atlassian.net/admin/jira-service-Management/portal-only-customers)

  2. Search for the duplicated user

  3. Click on the three dots icon (•••) > Migrate to Atlassian account button

When you migrate a customer to Atlassian account, Jira does the following:

  • Deactivate their portal-only profile
  • Migrate important data, such as their requests, to a new Atlassian account
  • Assign a new user key to the Atlassian account

The old portal-only profile still displays as Inactive, but you can't un-migrate it.

Which account is best for my customers?


External Customers

Internal Customers

These users can?

  • Send requests using the portal or email

  • View the knowledge base articles in the portal

  • Everything that an external customer has, plus:

  • Be licensed on other cloud products

  • Configure SAML SSO for these accounts. Learn how to set up SAML SSO.

Customers who you?

  • View strictly as a client

  • Collaborate with, or may need more access in the future

These customers can be found under?

  • User Management > Jira Service Management (YourDomain.atlassian.net/admin/jira-service-Management/portal-only-customers). Learn how to add external customers.

  • User Management > Users (YourDomain.atlassian.net/admin/users). Learn how to add internal customers.

  • In their profiles, they either have licenses to other Jira Cloud products or have no checkboxes ticked.

Where should they log in?

  • They must access the portal URL (YourDomain.atlassian.net/serviceManagement).

  • To find this URL in your project:

    1. In a Service Management project sidebar, select Customer channels.

    2. Copy the URL under Customer portal.

  • They can log in at your site's root URL (YourDomain.atlassian.net).

Last modified on Mar 26, 2024

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