JiraService Management > JQL for Initial Response completed() appears to be wrong

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Symptoms

JQL results for the following query returns X results when including Initial Response:

project = SUPPORT AND created >= 2014-09-01 AND created <=2014-09-30 AND "Initial Response" = completed()

JQL results for the following query, return Y results when omitting Initial Response:

project = SUPPORT AND created >= 2014-09-01 AND created <=2014-09-30

Cause

Only Time metrics are applied retroactively, not SLA outcomes. 

Workaround

In regards to reporting, we've added two charts that work differently to accommodate for this:

  • An elapsed time chart that displays the time metric values for all issues and a given time metric configuration. These values are always based on the current active definition and are recalculated if you change the definition. The idea is that this chart allows you to look at past/present performance, e.g. to evaluate where you would set the SLA target at in the first place. It also shows you how the team is currently doing in terms of elapsed time. Not the breached or not percentage is the question here, but how long things take on average.
  • An SLA breached/succeeded chart which is based on actual measured SLA outcomes. The values for this chart reflect the actual SLA outcomes stored against each issue. It tells you how the Service Management team actually did at a given moment in time with the SLA configuration at that time. Recalculating past values would make this chart much less meaningful

Additional reference materials:


Last modified on Feb 12, 2024

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