"Couldn't send request" message when raising a ticket.
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Symptoms
When trying to raise a ticket at the Customer Portal an error message shows up saying that the request could not be sent, because of an unsupported content you've entered into one or more of the issue fields.
Diagnosis
- Error message when trying to submit the request:
Error message in the log file:
errorMessage: "Your request could not be created. Please check the fields have been correctly filled in. We can't create this issue for you right now, it could be due to unsupported content you've entered into one or more of the issue fields. If this situation persists, contact your administrator as they'll be able to access more specific information in the log file." reasonCode: "400" reasonKey: "sd.validation.request.creation.failure.required.field"
Cause
A field was previously required in the workflow Create transition post function. However, this field was deleted, and the post function became invalid. Therefore the transition could not be completed, and the ticket could not be created.
- Before deleting the custom field:
- After deleting the custom field:
Note that in the "After" image, the second post function will be missing the name of the custom field it used to be after it was deleted.
Solution
You need to log in as a user with the Administer Jira global permission to access and manage workflows.
To resolve this issue, it will be necessary for you either remove the invalid post function or restore the custom field deleted.
For 60 days, you can view or restore the field from your Trashed field list. After 60 days, the field is permanently delete and any data stored against it. You can’t undo this.
Remove the invalid post-function:
- Go to your JSM Project > Project Settings.
- Workflows > Select the workflow the post-function is affecting > Click on the pencil icon to edit it.
- Check the "Show transition labels" checkbox > Select the affected transition.
- Post-Function > Find the invalid post-function and click on the "x".
- Publish the draft.
Restore the Custom field deleted:
- Go to your JSM Instance > Cog Icon > Issues.
- Under FIELDS, Select Custom fields.
- Trashed > Find the deleted custom field and click on the (...) icon.
- Restore the field.