Creating a data connection to use in Forms throws 404 errors
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Sometimes, creating a data connection using basic authentication following the steps shown Create, edit, test, or delete data connections for forms throws 404 errors.
Environment
Jira Service Management Cloud
Diagnosis
Analyzing the HAR file shows the below error
{
"code": 404,
"headers": [],
"contentType": "application/octet-stream",
"itemLocations": []
}
Cause
Jira encountered difficulties in establishing a secure connection to the desired destination due to our inability to verify the authenticity of the server's SSL/TLS certificate. This situation commonly arises when a self-signed certificate is utilized.
Solution
You would need to review the certificates added to the server that you are trying to add.
Some of the common tools available are:
https://www.digicert.com/help/
https://www.sslshopper.com/ssl-checker.html#hostname
https://www.sslchecker.com/sslchecker
In order for Forms to use external data, the following conditions must be met:
- The on-premise application you want to link to your Cloud site must be accessible via the supported ports: 80, 443, 8080, 8443, 8444, 7990, 8090, 8085, 8060, 8900, and 9900.
- If you want to use SSL, you must use a valid certificate (not a self-signed certificate. The list of the supported CA can be found HERE)
- Data Format: Valid JSON data
- List/Array of Objects: The JSON data must provide a list or array of objects.
- Object ID: The object must contain an ID value that is a number or a string. The ID is not displayed on the form.
- Object Value: Any individual string field within the object can be selected as the value to be displayed to users on the form.
- Size limitation: The API endpoint must return no more than 10MB of data
If you're using certificates generated using Sectigo then we have a known issue JRACLOUD-76343 - Getting issue details... STATUS that applies to Data Connections as well