CSV exported issues don't show AM, PM in Date/Time field

Summary

When Jira issues are exported from Jira, the exported file doesn't show AM/PM in a Date/Time custom field nor the time is in 24hr format. To know more about exporting Jira issues, refer to Export search results
   

        From Request                                           From CSV

Environment

Jira Cloud

Cause

 Complete Date/Time Format is not as per the required format.

Solution

The exported values of the date/time field are controlled by the Complete Date/Time Format in the Look and Feel (https://<Site-name>/secure/admin/LookAndFeel!default.jspa) section of Jira cloud instance.

Follow the below steps to add the am/pm marker:

  1. Navigate to Settings > USER INTERFACE > Look and Feel
  2. Scroll down to the Date / time formats section
  3. Click the value of Complete Date/Time Format, add "a" at the end of the value as shown in the below image
  4. Click Update
  5. Retry the export action

Refer to the following documentation: Change date and time formats and Java SimpleDateFormat



Last modified on Feb 28, 2024

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