CSV Import: Error when importing issues into a project <"Issue Creation Failed: User (displayname) doesn't exist">
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Scenario 1: The below Error is seen when a CSV Import is initiated from "External System Import" (under Jira global settings). The pre-validations are not shown in this method. We do get a hyperlink to the "Download Detailed log" for the import run.
Error: Issue Creation Failed: User "<user displayname" doesn't exist
Scenario 2: The below error is seen if you use the "Import issues" functionality from a local project "Issue Navigator" (Open Project > Issues > ... > Import issues from CSV). This method shows a validation summary and displays the errors that may occur after the import is complete.
Environment
JIRA Cloud
Diagnosis
- Check if the CSV file has "Assignee", "Reporter", and other User Picker Custom fields which have the user's "Display Name" as the value.
Cause
- The Assignee and Reporter in the CSV are “Display names” which Jira does not parse or resolve to email addresses or AAID (Atlassian Account ID).
Solution
- In the CSV file used for the import, make sure that the “Assignee ID” and “Reporter ID” columns are present.
- (For Scenario 1) Access the “External Import System” module
External System Import can be found at "JIRA Settings" > "System" > under "Import and Export" Select "External System Import" > "CSV".
Note: If you are not a "Jira Admin", you won't be able to use the "External Import System" module and hence you need to try these steps from the local project's "Issue Navigator"
(OR)
2. (For Scenario 2 )Project's "Issue Navigator" can be found at Project > "Issues" > Click on more options "Import Issue from CSV"
3. Map the "Assignee ID" (Atlassian account ID) value of the CSV to the"Assignee" Jira Field. Similarly, mapy the "Reporter ID" value for the “Reporter" field. (We usually map "Assignee" column from the CSV file to the "Assignee" JIRA field", which causes the above-mentioned error).
4. Proceed with the import operation.
If you have any other “CustomField - User picker” field, then it would not have the AAID Column for it in the CSV. In this case, the only option is to change the “display names” in CSV to their respective user “email address”.
If you still face issues and require assistance, kindly contact the Atlassian Support Team.