CSV import fails or creates another issue type because the issue type does not exist or its not applicable for the selected project in Jira
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
The CSV import may fail or create issues with a different issue type than expected.
In the import log, we can see a message reporting The issue type [ "..." ] does not exist or it's not applicable for the selected project
.
Environment
Jira Core 7.x and 8.x
Diagnosis
The message below is seen in the import logs (below's n example date/time):
2021-03-26 10:18:35,014 WARN - The issue type [ "Story" ] does not exist or it's not applicable for the selected project. The affected issues will be created with issue type [ Sub-task (sub-task) ]
The issue type reported in the log ("Story", in the example above) is present in the project's issue type scheme.
Cause
The CSV file had quotes or double quotes in the issue type column values and it shouldn't.
Eg.
Issue type Summary Priority "Story" My first imported story Minor Should be:
Issue type Summary Priority Story My first imported story Minor Without the double quotes.
The import might then fail or succeed with a different issue type because Jira selects the default issue type for that project. See How to change the default issue type displayed at the Create Issue screen for more info.
If the default issue type is a sub-task or requires certain fields by the field configuration or workflow, the import will fail.
Solution
Strip out the quotes or double quotes from the issue type column in the CSV and try the import again.
You may also take the opportunity to revisit the project's default issue type if that's the case.