Custom Field Column not Visible in Issue Navigator

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Symptoms

The Issue Navigator is configured to display an extra column (a Custom field) and the column appears every time you go to the "Configure your Issue Navigator" view, and allows you to move it to the different location, but it never shows when just looking at the filter in Issue Navigator.

Cause

The reason you are not seeing the custom field column in your Issue Navigator is that since it is constrained either by Issue Type or Context you will only ever see it if all the issues in the view are of the same issue type and that issue type is the one your custom field is configured against.

The reason for this is that it can be misleading to show a column with no values for issues that can not even have that value assigned.

The improvement request regarding this behaviour is being tracked at JRA-9367. Please add your comments to the discussion, vote on it and add yourself as a watcher for future updates.

Resolution

A possible workaround this restriction/limitation is to configure the custom fields with the global context or for all issue types.

Alternatively, as discussed in JRA-9367, you can do one of the following:

  • Include an "issuetype = " JQL clause to restrict the issue type or include a "project = " JQL clause to restrict the project (Depending on the custom field's context)
  • Include a "<fieldname> is not empty" JQL clause for at least one of the custom fields, or
  • (Less practical) Include a "key = " JQL clause for every issue you expect in your result.
Last modified on Feb 26, 2016

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