Custom field description not visible while creating a new issue for Jira service project
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
You are not able to see the description of the custom field when creating tickets even though the description is added in the field configuration for the Service project.
Environment
Jira Service Management Cloud
Diagnosis
The description of the custom field is not visible unless Use Request Type Field toggle is turned OFF.
Cause
This happens because the Use Request Type Field toggle is ON and the request form does not have any description for the custom field. Once you add the Custom field to the Request Form, the descriptions are not copied and only the name will be carried forward to Request Form.
When the toggle is turned ON, Jira takes field descriptions from the request form and not from the field configuration used in the service project.
Solution
There are two ways you can get the description for the custom field here:
- You can create any tickets for a service project with the Use Request Type Field toggle OFF. By doing so, the details of the fields are fetched from the field configuration of the service project and the custom field description will be displayed.
- You can add a description for the custom field in the Request form configuration, with this, any ticket created even with the Use Request Type Field toggle ON will fetch the description for the custom field from the request form configuration.
For more information, you can visit Get to know the project settings sidebar for service project.
In case the issue is still not resolved, feel free to contact Atlassian support.