Custom Field in JIRA is missing
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When searching through Administrator > Issues > Custom Fields, the custom field is not present
Diagnosis
- Run the following SQL query to check the contents of the Custom Field Description:
select * from customfield where cfname=<custom field name>;
Replace the <custom field name> with the name of the Custom Field that is missing.
- Verify the results and check to see if JavaScript is present in the Description field.
Cause
This could be caused by another Custom Field with the same name using JavaScript in the field description
Resolution
Remove any JavaScript from the Custom Field Description by updating the field:
- To ensure the correct Custom Field is being updated, use both the id and field name when updating the description via the database:
update customfield set description='' where id=<custom field id> and cfname=<custom field name>;
Replace the <custom field id> and <custom field name> in the above query. The ID can be retrieved from the query done during the Diagnosis.