Custom field permission errors with Jira Webhooks
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Configuring webhooks within Jira allows data to be sent to an external resource when certain events happen. Occasionally data transmitted as part of the webhook payload may contain permission errors for certain fields.
For further information on configuring Webhooks, please read the support article Manage Webhooks.
Diagnosis
Two examples of custom field errors seen in webhooks data that originate from Jira Service Management are with the Request type and SLA fields.
SLA field example:
A customer updates a ticket marking it as resolved via the customer portal, triggering a webhook event to an external site. SLA fields will be sent with an error similar to the one below:
"customfield_10052": {
"errorMessage": "You do not have permission to fetch the list of SLA custom fields",
"i18nErrorMessage": {
"i18nKey": "sd.sla.field.service.permission.error.fetch",
"parameters": []
}
},
Request type field example:
A user receives a customer satisfaction survey via email and clicks on the survey to complete it. The survey can be completed without having to log in to the customer portal, therefore in this case the request is treated as anonymous when being sent via the webhook service. Fields that require the user to be logged in will return the following error:
"customfield_10010": {
"errorMessage": "The action performed required a logged in user. Please log in and try again.",
"i18nErrorMessage": {
"i18nKey": "sd.admin.servicedesk.error.authenticated.user.required",
"parameters": []
}
},
Cause
The issue is due to the WebHook service impersonating the user making the request and certain custom fields such as the SLA field require the user making the request to be a Service Desk Agent or project Administrator. In certain situations it is possible for a user to update the ticket anonymously, such as when completing the customer satisfaction survey.
Solution
There are no methods in the Jira WebHook configuration to filter or identify requests made by portal customers or anonymous users and the below feature request intends to improve on how these errors are handled:
The custom field errors will need to be taken into consideration when aggregating the data received from Jira WebHooks and filtered or factored in accordingly in the receiving API endpoint.