Custom field values do not show up as options in Automations or cannot be searched via JQL

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

   

Summary

When adding a custom field such as a Select list field to a Jira Automation rule, the configured options are not listed or trying to search for the field as part of a JQL query an error is received indicating the field cannot be searched. When interacting with the field within the Issue View, users can still select values from the field.

Diagnosis

Trying to search for the custom field using JQL returns the error Field 'cf[10093]' is not searchable, it is only sortable. as seen in the screenshot below:

For automation rules, the field can be added to a rule element such as a field value condition, however trying to select an option for the value returns no data:

Cause

The field does not have a Search Template associated with it:

Solution

Setting a Search Template for the field will allow the field to be searched through JQL and the options to be listed via automation rules.

  1. Navigate to Settings (cog wheel icon upper right corner of Jira) > IssuesCustom fields
  2. Search for the impacted field using the field's name and click on the ⋯ button to the right of the field and select Edit
  3. In the Search Template drop down, select a template other than None

Related articles

The following article covers a scenario where due to Issue scope configuration on a custom field, data is not returned when searched via the issue search:

Last modified on Aug 31, 2023

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