Customer portal search doesn't find the request type name
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
The customer portal (help center) allows the user to search for request types, but it is missing when typing the exact name.
Environment
Jira Service Management Cloud.
Cause
This is an expected behavior, the search works with two different algorithms.
- The first search algorithm fetches the request types on a keyword-based match. If the search query term is "Request new hardware", then, requests with the title/description containing either "Request", or "new", or "hardware", or "New hire request" will be displayed.
- The second search algorithm doesn't search based on the title or description of the Request Types. Instead, it looks at recent issue activity. So, if the terms "Request", or "new", or "hardware" have been used recently in any issues, the Request Types of those issues will show up in the search results.
So, the hard limit of request types shown on the search result is 5. Currently, there is no sorting search by relevance, which means users don't see the search results they need.
Solution
We are working to mitigate this problem with the following feature requests:
JSDCLOUD-9400 - Getting issue details... STATUS
JSDCLOUD-9225 - Getting issue details... STATUS
Workaround
Add double quotes between the request type name to search for the exact name.