Customer portal throws "This form contains a hidden field that does not have a valid default value configured" when creating a new request

Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

 

Summary

When attempting to create a new request on the customer portal (JSM), the user receives the error message “This form contains a hidden field that does not have a valid default value configured”.

Environment

Jira Service Management (JSM) Data Center.

Diagnosis

To identify which field/value is preventing the new issue from being created we can use the browser's Developer Panel, per the instructions of Generating HAR files and analyzing web requests.

With the Developer Panel > Network tab open, try to create a new request and click on the 400 error entry, then select "Response".

Cause 1 - A user picker field has an inactive user as its default value

When inspecting the Server response, you see the error message: "User '<YourUser>' is not valid for this user picker.".
(info) Note that below the error message, the server response informs which field has the invalid user configured.

This occurs when there is a User Picker field with an inactive user set as part of its default value.

Example:

Cause 2 - A required field has no value assigned

When inspecting the Server response you see the error message: "Please provide a value for required field '<YourField>'".

This occurs when there is a User Picker field with an inactive user set as part of its default value.



Solution 1

Edit the default value set for the identified field, and remove the inactive user from it through either Jira administration (gear icon) > Issues > Custom fields > Configure contexts > Edit default value or Project settings > Request type > Edit Fields.

(lightbulb)If you are unsure of which field is the one causing issues, you can use the field ID informed below the error message on the URL below:
Be sure to replace <JiraBaseURL> and <customfield_ID> with the actual base URL from your instance and the identified ID for the field.

  • <JiraBaseURL>/secure/admin/ConfigureCustomField!default.jspa?fieldId=<customfield_ID>

References: 

Solution 2

Either configure a preset value for the identified field on Project settings > Request type > Edit Fields, or make it an optional field on both Project settings > Request type > Edit Fields & Jira administration (gear icon) > Issues > Field Configuration.

References: 


Last modified on Jan 27, 2025

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