Customer tab in a Service Management (Service Desk) project is slow to load or spins indefinitely
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
The page showing the customers from a Service Desk Management project is extremely slow to loads, loads indefinitely or times out (in case Jira is configured with a reverse proxy):
Diagnosis
Bypassing the reverse proxy does not fix the issue: the page is still slow to load
- The issue only occurs with specific Service Management project(s)
- The Jira application contains a high number of users (at least thousands) and groups (at least hundreds), and each user is a member of multiple groups
- The Service Management application is on version 4.4.0 or higher
- The impacted Service Management projects are configured as "closed" (with the permission Who can raise requests? set to Customers who are added to the project in the page Project Settings > Customer Permissions)
Service Management projects which are configured as "opened" (with the permission Who can raise requests? set to Customers who have an account on this Jira site or Anyone can email the service project or raise a request in the portal) are not impacted
Cause
The reason why the Customer tab is very slow to load is a combination of multiple parameters:
- the fact that the impacted Service Management projects are "closed" (configured with the Customer permission set to Customers who are added to the project)
- the fact that the Customer search algorithm (used to populate the customer tab) was changed in Service Management 4.4.0 and is:
- optimized for Service Management Projects configured as opened
- not optimized for Service Management Projects configured as closed
For Service Management projects configured as "closed", the Customer page algorithm works like this:
- It loads each single Jira user from the entire application
- It filters out users who don't have access to the project (by filtering out users who are not granted the browse projects permission, or who are not added to the Service Desk customers project role)
- It filters out users that are considered as agents in the project
Since any type of user filtering requires checking users and group memberships, the higher the number of users and groups in the Jira application, the slower the search will be.
Workaround
This suggestion consists in following the steps below:
- Navigate to the URL http:<JIRA-base-URL>/secure/admin/SiteDarkFeatures!Default.jspa to open the Dark Features page
- Enter sd.use.search.by.permissions.disabled inside the box Enable dark feature and click on the Add button. After you do it, you should see a new line in this page as shown in the screenshot below:
Adding this new line to the dark feature will basically disable the new customer search that was introduced in Service Desk 4.4.0, and which is likely to cause the slowness in the Service Management project.
If adding this dark feature does not resolve the loading issue, please raise a ticket at Atlassian Support for further investigation.