Customers unable to raise tickets and get error "This request is only available to users with Jira access."
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Customers unable to raise tickets
Error when trying to open a ticket in the portal:
We couldn't load this request
This request is only available to users with Jira access. Select a different request, or contact your admin.
Environment
Jira Service Management Cloud
Cause
The Affected Services field is one that is only available to users with a license. Linking a form field to this field and making it mandatory would result in the above error.
While forms do support this field but it would still need a license to update it. Customers will see this warning if this field is part of the form but not a required field, they can proceed to create the issue successfully without filling this field
Solution
In the form builder, unlink the Jira field(Affected services) and add the same choices in the form field as that in the Jira field.
This would allow customers to select the Affected Service(and this input is stored in the Form field)
Two solutions to update the Jira field
- Agents can update this field manually after issue creation. They can verify and update the Jira field based on the value in form.
Use automation to update the field
a. Create a custom Jira field of type Select List (single choice) and update the same values from the Affected Services system field
Add a new custom field to a service project
Customize the fields of a request type
b. Link this field from above to the form field
c. Create an automation rule to update the system field with the value from the custom field
Simple rule using IF blocks
Rule using Advance Field Editing using JSON{ "fields": { "Affected services":[{"id": "{{issue.customfield_10181}}"}] } }
You can use the name of the field or the ID in the above smart value. Replace 10181 with the ID from your cloud site
You can find the right value using Find the smart value for a field