DataAccessException on Issues with Assignees that Have Been Deleted from Crowd

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Symptoms

  1. Re-assigning an issue fails with a DataAccessException.

  2. In some cases the Project Gadget may not render if the projet lead has been deleted.

The following appears in the atlassian-jira.log:

com.atlassian.jira.exception.DataAccessException: Error occurred while retrieving user with id

Cause

If the assignee has been deleted from the Crowd repository (either LDAP or local), it is not possible to re-assign issues. Please refer to  CWD-202 - Getting issue details... STATUS  for further information.

Workaround

One of the unfortunate aspects of this bug is that JIRA will not let you re-assign any issues for which the deleted user is the assignee, because it instead throws the DataAccessException. The workaround is to re-create the user in Crowd. Then you can re-assign the issue, as the exception will not be thrown.

You can then deactivate the unwanted user. Please deactivate a user, rather than delete them.

Last modified on Mar 30, 2016

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