DataAccessException on Issues with Assignees that Have Been Deleted from Crowd
Symptoms
Re-assigning an issue fails with a DataAccessException.
- In some cases the Project Gadget may not render if the projet lead has been deleted.
The following appears in the atlassian-jira.log
:
com.atlassian.jira.exception.DataAccessException: Error occurred while retrieving user with id
Cause
If the assignee has been deleted from the Crowd repository (either LDAP or local), it is not possible to re-assign issues. Please refer to - CWD-202Getting issue details... STATUS for further information.
Workaround
One of the unfortunate aspects of this bug is that JIRA will not let you re-assign any issues for which the deleted user is the assignee, because it instead throws the DataAccessException. The workaround is to re-create the user in Crowd. Then you can re-assign the issue, as the exception will not be thrown.
You can then deactivate the unwanted user. Please deactivate a user, rather than delete them.